How to install sysbench 0.5 on Debian 7

Normally, sysbench 0.4.12 version can be installed from repositories like “apt-get install sysbench” but the newer version 0.5 is not added in any repo yet (AFAIK) so, it’s bit difficult to install it. 1. Install bzr package if it’s not installed. (i.e apt-get install bzr) 2. Download the code from branch. (i.e bzr branch lp:sysbench) …

FATAL: failed to initialize database driver! with Sysnbech 0.4.X

Recently, I came through with this error. It was weird because I have never seen this error earlier. [root@percona-pxc55-1 nilnandan]# sysbench –test=oltp –oltp-table-size=1000000 –mysql-db=dbtest –mysql-user=msandbox –mysql-password=msandbox –mysql-socket=/tmp/mysql_sandbox5537.sock prepare sysbench 0.4.12: multi-threaded system evaluation benchmark FATAL: no database driver specified FATAL: failed to initialize database driver! [root@percona-pxc55-1 nilnandan]# After some research, found that with Sysbench 0.4.x,…

dpkg: dependency problems prevent configuration of mysql-workbench-community for Ubuntu 13.04

While installing mysql-workbench-community-6.0.9 on Ubuntu 13.04 if you get below error. root@Dell-XPS:/home/nilnandan/Downloads# dpkg -i mysql-workbench-community-6.0.9-1ubu1204-amd64.deb Selecting previously unselected package mysql-workbench-community. (Reading database … 203112 files and directories currently installed.) Unpacking mysql-workbench-community (from mysql-workbench-community-6.0.9-1ubu1204-amd64.deb) … dpkg: dependency problems prevent configuration of mysql-workbench-community:  mysql-workbench-community depends on libctemplate0; however:   Package libctemplate0 is not installed.  mysql-workbench-community depends on…

Percona server 5.5/5.6 installation failed on Ubuntu 13.04/13.10(amd64)

While installing Percona Server 5.5/5.6 on Ubuntu 13.04/13.10, I got some weird errors, which I never faced before. Errors were something like, dpkg: error processing /var/cache/apt/archives/libmysqlclient18_1%3a5.5.35-rel33.0-611.raring_amd64.deb (–unpack):   libmysqlclient18:amd64 1:5.5.35-rel33.0-611.raring (Multi-Arch: no) is not co-installable with libmysqlclient18 which has multiple installed instances shell>  sudo apt-get install percona-server-server-5.5 Reading package lists… Done Building dependency tree Reading…

How to install Canon MP287 scanner in ubuntu 12.04

It’s bit tricky but easy to install. Download both printer/scanner deb packages from below location: http://support-in.canon-asia.com/contents/IN/EN/0100301402.html http://support-in.canon-asia.com/contents/IN/EN/0100302702.html Untar and install .deb packages in ubuntu. You can also install by running ./install.sh i.e tar -xzvf cnijfilter-mp280series-3.40-1-deb.tar.gz cd cnijfilter-mp280* ./install.sh Now, check that your scanner is being detected or not. shell$ sane-find-scanner   # sane-find-scanner will now…

How to enable compositing in ubuntu 10.10

Some time after installing of ubuntu, we are getting errors with visual effects/any dock tools like docky or AWN/ubuntu themes. i.e “You need to unable Desktop Effects (Compositer) to apply and customise themes. Following are the simple steps to get rid out of that error. Press Alt-F2 to open the “Run Application” box / Open…

How to install Drupal 7.0 on Ubuntu 10.04

Drupal is a free and robust content-management system which runs on LAMP(Linux, Apache, MySQL and PHP) server. PostgreSQL and MariaDB are also compatible with with Drupal. Before start Drupal 7.0 installation, we have to install following packages related to LAMP. Here, I’m imagine that Ubuntu 10.04 is already installed 🙂 – A web server. Apache…